Call Handling Issue
Incident Report for Jive Communications, Inc
Resolved
This incident has been resolved.
Posted Jan 15, 2018 - 13:30 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2018 - 12:44 EST
Investigating
Beginning around 10:15 Mountain time, some Jive customers began to experience Call Handling issues that are preventing inbound and outbound calls.

Jive engineers are working quickly to restore services. Our sincere apologies for the disruption.
Posted Jan 15, 2018 - 12:37 EST
This incident affected: PBX Service.