Call Handling Issues
Incident Report for Jive Communications, Inc
Resolved
This incident has been resolved.
Posted Aug 14, 2018 - 22:30 EDT
Investigating
Beginning around 8:30 PM Mountain Time, we became aware of an issue that is affecting a small subset of our customers. Our engineers worked quickly to resolve the issue.
Posted Aug 14, 2018 - 22:24 EDT
This incident affected: PBX Service.